X


ΠΑΝΕΛΛΗΝΙΕΣ 2017

ΕΝΔΕΙΚΤΙΚΑ ΘΕΜΑΤΑ: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον

 

Εκφωνήσεις

ΘΕΜΑ Α

Α1. Απαντήστε με σωστό ή λάθος                                                                                      (μονάδες 10)

1.    Κάθε γλώσσα προσδιορίζεται από το αλφάβητο της, το λεξιλόγιο της, τη γραμματική της και τη σημασιολογία της. Σ Λ
2.    Για την αρχική σύνταξη των προγραμμάτων και τη διόρθωση τους χρησιμοποιείται ένα ειδικό πρόγραμμα που ονομάζεται συνδέτης. Σ Λ
3.    Τα σύγχρονα ολοκληρωμένα προγραμματιστικά περιβάλλοντα παρέχουν μόνο μεταφραστή μιας γλώσσας προγραμματισμού. Σ Λ
4.    Το τμήμα του προγράμματος που ισχύουν οι μεταβλητές λέγεται εμβέλεια προγράμματος. Σ Λ
5.    Στο δομημένο προγραμματισμό κάθε πρόγραμμα όπως και κάθε ενότητα προγράμματος έχει μόνο μία είσοδο και μόνο μία έξοδο. Σ Λ

 

Α2. Ποιές οι διαφορές τεχνικών και φυσικών γλωσσών;                                                    (μονάδες 7)

 

Α3. Να γίνει αντιστοίχιση.                                                                                                     (μονάδες 8)

Στήλη Α Στήλη Β
1.    Προσθήκη νέων κόμβων σε μία υπάρχουσα δομή. α.   Προσπέλαση

β.   Αντιγραφή

γ.   Διαγραφή

δ.   Αναζήτηση

ε.   Εισαγωγή

στ. Ταξινόμηση

2.    Οι κόμβοι μιας δομής διατάσσονται κατά αύξουσα ή φθίνουσα σειρά.
3.    Πρόσβαση σε ένα κόμβο με σκοπό να εξετασθεί ή να τροποποιηθεί το περιεχόμενο του.
4.    Όλοι οι κόμβοι ή μερικοί από τους κόμβους μιας δομής αντιγράφονται σε μια άλλη δομή.

            ΣΗΜΕΙΩΣΗ: Δύο στοιχεία της Στήλης Β δεν χρησιμοποιούνται.

 

Α4. Να μετατρέψετε το παρακάτω τμήμα αλγορίθμου στις άλλες δύο επαναληπτικές δομές (αν αυτό είναι εφικτό).                                                                                                                                (μονάδες 10)

ψ← 0

κ←1

αρχή_επανάληψης

            διάβασε χ

            ψ← ψ-χ

            ω←κ+ψ

            κ← κ+4

            λ← κ*2 –χ

            εμφάνισε ω,λ

μέχρις_ότου κ>100

εμφάνισε ψ

 

 

Α5. Συμπληρώστε τα κενά με τις λέξεις που λείπουν.                                                          (μονάδες 5)

  1. Μία ………….. είναι μία μεταβλητή που επιτρέπει το πέρασμα της τιμής της από ένα τμήμα προγράμματος σε ένα άλλο.
  2. Η λίστα των……………. παραμέτρων καθορίζει τις παραμέτρους στη δήλωση του υποπρογράμματος.
  • Η λίστα των……………. παραμέτρων καθορίζει τις παραμέτρους στην κλήση του υποπρογράμματος.
  1. Μερικές γλώσσες προγραμματισμού ονομάζουν …………….. τις τυπικές παραμέτρους και απλά …………….. τις πραγματικές παραμέτρους.

ΘΕΜΑ Β

Δίνεται το τμήμα προγράμματος:

α 1

ΔΙΑΒΑΣΕ β

ΑΝ α > β ΤΟΤΕ

ΚΑΛΕΣΕ διαδ (α,β)

     ΓΡΑΨΕ α,β

ΑΛΛΙΩΣ

     ΓΡΑΨΕ συναρ(α,β)  

ΤΕΛΟΣ_ΑΝ

 

ΔΙΑΔΙΚΑΣΙΑ διαδ (χ,ψ)

ΜΕΤΑΒΛΗΤΕΣ

     ΑΚΕΡΑΙΕΣ: i

     ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ, κ, λ

ΑΡΧΗ      

ΓΙΑ i ΑΠΟ 10 ΜΕΧΡΙ 20 ΜΕ_ΒΗΜΑ 3

              κ χ + ψ - i

              λ 2 * i

              ΓΡΑΨΕ κ, λ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

χ κ

ψ λ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 

ΣΥΝΑΡΤΗΣΗ συναρ(χ,ψ):ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ

     ΑΚΕΡΑΙΕΣ: i, χ,ω

     ΠΡΑΓΜΑΤΙΚΕΣ: ψ

ΑΡΧΗ                  

ΓΙΑ i ΑΠΟ χ ΜΕΧΡΙ ψ

              ω 2 * i

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

συναρ ω * i

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

  1. Αν διαβαστεί ο αριθμός 6 τι θα εμφανιστεί;            (μονάδες 6)
  2. Αν διαβαστεί ο αριθμός 0 τι θα εμφανιστεί;           (μονάδες 6)
  • Να γραφεί το αντίστοιχο τμήμα προγράμματος χωρίς τη χρήση των υποπρογραμμάτων

(μονάδες 8)

ΘΕΜΑ Γ

Μία μεταφορική εταιρία διαθέτει 30 φορτηγά με ωφέλιμο φορτίο 7 τόνους το καθένα. Το κόστος μεταφοράς κάθε τόνου είναι 450€. Να γραφεί πρόγραμμα το οποίο

  1. Θα διαβάζει τα φορτία (σε κιλά) που φορτώνονται στα φορτηγά μέχρι να γεμίσουν και τα 30 φορτηγά. Η φόρτωση σε κάθε φορτηγό θα γίνεται μέχρι να βρεθεί φορτίο που δεν χωράει να φορτωθεί οπότε το φορτίο αυτό θα μπει στο επόμενο φορτηγό.            (μονάδες 8)
  2. Θα υπολογίζει και θα εμφανίζει το συνολικό φορτίο σε κάθε φορτηγό.            (μονάδες 4)
  • Θα υπολογίζει και θα εμφανίζει το μέσο φορτίο ανά φορτηγό.            (μονάδες 2)
  1. Θα εμφανίζει το φορτηγό ή τα φορτηγά με το μέγιστο φορτίο.            (μονάδες 4)
  2. Θα υπολογίζει και θα εμφανίζει το συνολικό κόστος της μεταφοράς.            (μονάδες 2)

 

ΘΕΜΑ Δ

Ένας επιχειρηματίας που διαθέτει αίθουσες δεξιώσεων χωρητικότητας 50 τραπεζιών (το κάθε τραπέζι είναι 10 ατόμων) σας αναθέτει να φτιάξετε πρόγραμμα το οποίο

  1. Θα περιέχει τμήμα δηλώσεων.            (μονάδες 2)
  2. Θα ζητά από το χρήστη τον αριθμό των τραπεζιών που θα χρειαστεί ελέγχοντας ότι πρόκειται για αποδεκτό αριθμό.            (μονάδες 2)
  • Θα αποθηκεύει σε δισδιάστατο πίνακα τα ονόματα των ατόμων ανά τραπέζι (οι γραμμές αντιστοιχούν στους αριθμούς των τραπεζιών και οι στήλες στα καθίσματα ).            (μονάδες 2)
  1. Θα διαβάζει το όνομα ενός καλεσμένου και θα εμφανίζει το τραπέζι που κάθεται. Αν το όνομα δεν υπάρχει να εμφανίζει κατάλληλα διαμορφωμένο μήνυμα.(θεωρείστε ότι κάθε όνομα είναι μοναδικό)                                                                                                                  (μονάδες 7)
  2. Θα διαβάζει τον αριθμό ενός τραπεζιού και να εμφανίζει αλφαβητικά τα ονόματα των ατόμων που κάθονται στο τραπέζι.                                                                                         (μονάδες 7)

 

Απαντήσεις

ΘΕΜΑ Α

Α1. 1 → Σ, 2 → Λ, 3 → Λ, 4 → Λ, 5 → Σ.

Α2. Σχολικό βιβλίο σελ 116

Α3. 1 → ε, 2 → στ, 3 → α, 4 → β

Α.4

ψ← 0

κ←1

όσο κ<=100 επανάλαβε

διάβασε χ

ψ← ψ-χ

ω←κ+ψ

κ← κ+4

λ← κ*2 –χ

εμφάνισε ω,λ

τέλος_επανάληψης

εμφάνισε ψ

ψ← 0

για κ από 1 μέχρι 100 με_βήμα4

διάβασε χ

ψ← ψ-χ

ω←κ+ψ

λ← (κ+4)*2 –χ

εμφάνισε ω,λ

τέλος_επανάληψης

εμφάνισε ψ

Α5.

  1. παράμετρος
  2. τυπικών
  • πραγματικών
  1. ορίσματα, παραμέτρους.

 

ΘΕΜΑ Β

  1. Εμφανίζεται ο αριθμός 84
  2. Εμφανίζονται οι αριθμοί -9     20

-12   26

                                             -15   32

-18   38

-18   38

α 1

ΔΙΑΒΑΣΕ β

ΑΝ α > β ΤΟΤΕ

ΓΙΑ i ΑΠΟ 10 ΜΕΧΡΙ 20 ΜΕ_ΒΗΜΑ 3

κ α + β - i

λ 2 * i

ΓΡΑΨΕ κ, λ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α κ

β λ

ΓΡΑΨΕ α,β

ΑΛΛΙΩΣ

ΓΙΑ i ΑΠΟ α ΜΕΧΡΙ β

ω 2 * i

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

σ ω * i

ΓΡΑΨΕ  σ

ΤΕΛΟΣ_ΑΝ

 

 

ΘΕΜΑ Γ

ΠΡΌΓΡΑΜΜΑ Θ_3

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: i

ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝ_ΦΟΡ, MAX, ΦΟΡΤΙΟ, Φ[ 30], S, ΜΕΣΟ_ΦΟΡΤΙΟ, ΚΟΣΤΟΣ

ΑΡΧΗ

ΣΥΝ_ΦΟΡ  ← 0

MAX ← -1

ΔΙΑΒΑΣΕ ΦΟΡΤΙΟ

ΓΙΑ  i ΑΠΟ 1 ΜΕΧΡΙ 30

S ← 0

ΌΣΟ S+ΦΟΡΤΙΟ <= 7000 ΕΠΑΝΑΛΑΒΕ

S ←  S+ΦΟΡΤΙΟ

ΔΙΑΒΑΣΕ ΦΟΡΤΙΟ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Φ[ i] ←  S

ΓΡΑΨΕ S

ΑΝ S > MAX ΤΟΤΕ

MAX ←  S

ΤΕΛΟΣ_ΑΝ

ΣΥΝ_ΦΟΡ  ←  ΣΥΝ_ΦΟΡ + S

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ  ΣΥΝ_ΦΟΡ

ΓΙΑ  i ΑΠΟ 1 ΜΕΧΡΙ 30

ΑΝ  Φ[ i] = MAX ΤΟΤΕ

ΓΡΑΨΕ i

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΜΕΣΟ_ΦΟΡΤΙΟ ←  ΣΥΝ_ΦΟΡ /30

ΚΟΣΤΟΣ←  ΣΥΝ_ΦΟΡ * 450 /1000

ΓΡΑΨΕ  ΜΕΣΟ_ΦΟΡΤΙΟ, ΚΟΣΤΟΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

 

ΘΕΜΑ Δ

ΠΡΟΓΡΑΜΜΑ Θ_4

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ:  i, j, γρ, θ,  ΑΡ_ΤΡ,

ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[50,10],  name

ΛΟΓΙΚΕΣ:f

ΑΡΧΗ

ΑΡΧΗ_ ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ ΑΡ_ΤΡ

ΜΕΧΡΙΣ_ΟΤΟΥ  ΑΡ_ΤΡ>0  ΚΑΙ  ΑΡ_ΤΡ<=50

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ  ΑΡ_ΤΡ

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ  10

ΔΙΑΒΑΣΕ ΟΝ[i,j]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ  name

θ ← 0

i ← 1

f ← ΨΕΥΔΗΣ

ΌΣΟ ( i < = ΑΡ_ΤΡ)  ΚΑΙ ( f = ΨΕΥΔΗΣ)  ΕΠΑΝΑΛΑΒΕ

j  ← 1

ΌΣΟ ( j < = 10)  ΚΑΙ ( f = ΨΕΥΔΗΣ)  ΕΠΑΝΑΛΑΒΕ

ΑΝ ΟΝ[i,j] =  name ΤΟΤΕ

θ ←  i

f ← ΑΛΗΘΗΣ

ΑΛΛΙΩΣ

j ← j+ 1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

i ← i + 1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ  f = ΑΛΗΘΗΣ  ΤΟΤΕ

ΓΡΑΨΕ θ

ΑΛΛΙΩΣ

ΓΡΑΨΕ  «το όνομα αυτό  δεν υπάρχει»

ΤΕΛΟΣ_ΑΝ

ΑΡΧΗ_ ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ γρ

ΜΕΧΡΙΣ_ΟΤΟΥ  γρ>0  ΚΑΙ  γρ<=  ΑΡ_ΤΡ

ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ  10

ΓΙΑ j ΑΠΟ 10 ΜΕΧΡΙ  i ΜΕ_ΒΗΜΑ -1

ΑΝ ΟΝ[γρ,j-1] >  ΟΝ[γρ,j] ΤΟΤΕ

temp← ΟΝ[γρ,j-1]

ΟΝ[γρ,j-1] ← ΟΝ[γρ,j]

ΟΝ[γρ,j] ← temp

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ  10

ΓΡΑΨΕ ΟΝ[γρ,j]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Επιμέλεια θεμάτων: Νικολάου Ειρήνη, καθηγήτρια Πληροφορικής και Μαθηματικών, καθηγήτρια των Φροντιστηρίων «ΧΡΟΝΟΣ»

Τα θέματα και οι απαντήσεις τους βρίσκονται στις Εκδόσεις των Φροντιστηρίων «ΧΡΟΝΟΣ»

Για να δείτε τα θέματα κι από άλλα μαθήματα, παρακαλώ πατήστε εδώ

Πως μπορούμε να σας φανούμε χρήσιμοι;




Συμπληρώστε τα ακόλουθα πεδία και θα επικοινωνήσουμε άμεσα μαζί σας.
Εναλλακτικά, μπορείτε να επικοινωνήσετε με όλους τους διαθέσιμους τρόπους
που βλέπετε δεξιά από τη φόρμα επικοινωνίας

Παράρτημα #1 Αχαρνές:
Διεύθυνση: Αγίας Τριάδος 15-17
Τηλ: 210 2445106, 210 2445107


Παράρτημα #2 Θρακομακεδόνες:
Διεύθυνση: Λ.Θρακομακεδόνων 220-222
Τηλ: 210 2430756, 210 2430832